city website slugglish to load

Incident Report for City of Pleasanton Systems

Resolved

Happy to report that the city website performance issue has been fully resolved. The site is now loading normally.

We apologize for any inconvenience this may have caused and appreciate your understanding.
Posted Jun 11, 2026 - 16:49 PDT

Monitoring

Solutions have been applied to mitigate the website loading issue. We are currently monitoring the issue. Thanks to all for reporting this.
Posted Jun 09, 2026 - 15:59 PDT

Identified

We have received reports and are experiencing city website's sluggish issue. We have identified the issue and actively working on restoring the service.
Posted Jun 09, 2026 - 15:38 PDT
This incident affected: www.cityofpleasantonca.gov and Pleasanton Library Web Page.