Service has been restored and is performing normally for most users after configuration updates. We’re monitoring performance and stability as usage increases. No action required.
Posted Sep 18, 2025 - 21:08 PDT
Update
IT is currently working on implementing an additional security layer for VPN. Limited VPN access may be made available in the interim. We will share further updates as soon as they become available. Thank you for your patience.
Posted Sep 18, 2025 - 09:57 PDT
Identified
We are currently experiencing an unexpected interruption with our GlobalProtect VPN service. Access has been temporarily disabled while we work on restoring stable connectivity.
Our team is actively investigating the issue and implementing solutions to ensure a secure and reliable service. We will provide updates as soon as more information becomes available.
Thank you for your patience and understanding.
Posted Sep 15, 2025 - 23:45 PDT
This incident affected: Global Protect (remote access).