5/2/25 - City Website Outage

Incident Report for City of Pleasanton Systems

Resolved

The hosting web infrastructure has remained stable since the incident, and all monitoring indicators confirm that services are operating normally. We are now closing this particular incident. That said, the IT team is conducting a root cause analysis and will explore additional measures to enhance the reliability of this critical platform moving forward.
Posted May 02, 2025 - 13:43 PDT

Update

We have identified and resolved the issue that caused the temporary outage of the city website. The site is now operational, and all services appear to be functioning normally.

Our team is currently monitoring the system closely to ensure continued stability and performance. We will continue to observe the platform for any anomalies and take immediate action if necessary.

We appreciate your patience and understanding.
Posted May 02, 2025 - 08:33 PDT

Monitoring

The affected sites have been restored. IT is analyzing the root cause and will continue monitoring system stability before formally closing this incident.
Posted May 02, 2025 - 08:11 PDT

Investigating

We are experiencing an outage affecting the City of Pleasanton’s website and several hosted online services. Our IT team is actively investigating the issue and working to restore access as quickly as possible.

We apologize for the inconvenience and appreciate your patience. We will provide updates here as more information becomes available.
Posted May 02, 2025 - 07:32 PDT
This incident affected: www.cityofpleasantonca.gov, Pleasanton Library Web Page, Utility Billing Payment Portal, www.inpleasanton.com, and www.pleasantonpermits.com.