Laserfiche is offline
Incident Report for City of Pleasanton Systems
Resolved
This incident has been resolved. Thank you.
Posted Feb 09, 2024 - 15:02 PST
Investigating
Laserfiche is offline. We are currently looking into the issue.
Posted Feb 09, 2024 - 14:49 PST
This incident affected: Laserfiche - Public Records Search.