The Telephone and Voicemail incident has been resolved.
Posted Mar 16, 2026 - 16:46 PDT
Monitoring
The VMware infrastructure issue has been resolved. Services have been restored and are operating normally at this time.
We will continue to closely monitor the environment to ensure stability and will provide further updates if needed.
Posted Feb 26, 2026 - 16:13 PST
Update
We are continuing to investigate this issue.
Posted Feb 26, 2026 - 16:11 PST
Investigating
We are currently investigating a VMware infrastructure issue that is impacting the EMS Room Reservation system and Mitel phone/voicemail services.
At this time, we have identified that the affected virtual machines are experiencing connectivity and performance instability within the VMware environment.
Thank you for your patience while we work to resolve the issue.
Posted Feb 24, 2026 - 09:54 PST
Monitoring
A fix has been applied and we are monitoring network connectivity, servers that were having connection issues have been stable.
Thank you for your patience during this issue.
Posted Feb 23, 2026 - 08:13 PST
Investigating
We are currently experiencing a partial outage impacting Mitel desk phones, the Mitel app, and main incoming lines related to server infrastructure.
Impacted Services:
Desk phone connectivity and call handling
Mitel desktop application access
Main line inbound and outbound calling
We are actively investigating the underlying cause within the server infrastructure and working to restore full service as quickly as possible.
We will provide additional updates as more information becomes available.