Business License - Progressive software

Incident Report for City of Pleasanton Systems

Resolved

The issue affecting PSI software has been resolved by IT. Users should now be able to access the system normally.
Posted Jan 29, 2026 - 16:11 PST

Investigating

Our IT team is currently investigating an issue affecting PSI software, both internal access as well as Online renewal access. We will share updates as they become available.
Posted Jan 29, 2026 - 16:05 PST
This incident affected: Online Business License Renewal.