ESS(Employee Self Service) is offline

Incident Report for City of Pleasanton Systems

Resolved

The incident has been resolved. Thank you for your patience.
Posted May 09, 2025 - 11:09 PDT

Investigating

We are currently investigating the issue.
Posted May 09, 2025 - 10:23 PDT
This incident affected: Tyler Munis - Selfservice Portal.