Pleasanton Library – BiblioCore Website Outage

Incident Report for City of Pleasanton Systems

Resolved

This incident has been resolved.
Posted Jul 24, 2026 - 12:07 PDT

Monitoring

From BiblioCommons:

Thursday, July 23, 2026, 5:15PM PT - We have been seeing stability and our engineers continue to monitor. Further updates will be posted here.
Posted Jul 23, 2026 - 17:52 PDT

Update

From BiblioCommons:

Thursday, July 23, 2026, 4:26PM PT - While most libraries were seeing their sites come back, some are seeing the 503 errors return. Our engineers are still investigating
Posted Jul 23, 2026 - 16:34 PDT

Investigating

We are aware of an outage affecting the Pleasanton Library’s BiblioCore website (pleasantonlibrary.bibliocommons.com), a hosted service provided by BiblioCommons.

Our monitoring systems detected the site becoming unavailable at approximately 3:06 PM PDT on Thursday, July 23, 2026, with HTTP 503 Service Unavailable errors reported by external uptime alerts.

BiblioCommons has acknowledged a broader issue affecting BiblioCore sites and indicated that its engineers are actively investigating the cause of these errors.

City of Pleasanton IT is monitoring the situation and will share updates from BiblioCommons as they become available or when service is restored.
Posted Jul 23, 2026 - 15:48 PDT
This incident affected: Pleasanton Library Systems.