Laserfiche Public Records Search Access Issues

Incident Report for City of Pleasanton Systems

Resolved

This incident has been resolved.
Posted Feb 11, 2026 - 14:59 PST

Identified

We are currently experiencing issues accessing the City’s Laserfiche Public Records Search portal.

Automated traffic from search engines and AI bots is consuming all available concurrent access licenses, potentially preventing residents and staff from searching or viewing public records. Our IT team is actively investigating mitigation options and working with our vendor to restore stable access as quickly as possible.
Posted Feb 11, 2026 - 09:49 PST
This incident affected: Laserfiche - Public Records Search.